Accueil du site > INFORMATIQUE > PHP > Deux PHP.INI pour PHP4 et PHP5 avec XAMPP pour Linux

Deux PHP.INI pour PHP4 et PHP5 avec XAMPP pour Linux

lundi 29 janvier 2007, par Thierry Bothorel

XAMPP pour Linux est remarquable pour son automatisation du passage de PHP4 à PHP5. Mais auparavant sous Windows j’avais l’habitude d’utiliser un fichier PHP.INI différent selon la version de PHP utilisée.

Malheureusement XAMMP pour Linux utilise le même fichier pour les deux configurations et il est souvent utile d’avoir des paramètres différents, pour les extensions par exemple, etc…

Qu’à cela ne tienne, ce n’est pas trop difficile à changer. Tout ce qui suit se fait en root.

- Faire deux copies de /opt/lampp/etc/php.ini de façon a avoir deux fichiers php.ini-4.4.2 et php.ini-5.1.2. Respectez bien l’ortographe pour la suite.

- Supprimer le fichier /opt/lampp/etc/php.ini

- Créer un lien symbolique sur un des deux fichiers php.ini.xxx (celui correspondant à la version en cours) en le nommant php.ini.

- Ouvrir dans un éditeur le fichier /opt/lampp/share/lampp/activatephp

- Juste avant la dernière ligne :

/opt/lampp/lampp restartapache

insérer les lignes suivantes de telle façon que la fin du fichier soit comme ceci ;

Voilà, maintenant lorsque vous changerez la version active de php, le version de php.ini utilisée sera différente également. Il ne vous reste plus qu’à personnaliser votre /opt/lampp/etc/php.ini-4.4.2 et php.ini-5.1.2 à votre guise.

Répondre à cet article | RétroLiens :0


Répondre à cet article