Using PDT : Installation : Installing PDT

From PDTWiki

Jump to: navigation, search

There are three ways to install this plugin, all-in-one package, automated or manual.

All-in-one package

If you don’t already have a working copy of the Eclipse Platform and just want to try out the PHP Development Tool (PDT), there is an out-of-the-box solution for you:

  1. Install the Java 2 Standard Edition 1.4.2
  2. Download the PDT All-in-One package and install it.

Everything should work fine out of the box.

The "PDT All-in-One package" includes:

Automated

An automated installation of PDT is available via the Eclipse Update Manager (following steps based on Eclipse SDK 3.2.1).

  1. First off, if you have PHPeclipse installed, you’ll need to disable it:
    • In the Eclipse main menu, navigate to Help > Software Updates > Manage Configuration.
    • Browse the tree on the left side to find the entry “PHPeclipse”. Highlight it and choose the “Disable” link from the pane on the right.
      Figure 1: “Disable PHPeclipse”

  2. Now we can continue downloading PDT.
    • Navigate to Help > Software Updates > Find/Install in the Eclipse main menu (see Figure 2: “Find and Install...”).
      Figure 2: “Find and Install...”

    • Select the radio button labeled: “Search for new features to install” (see Figure 3: “Feature Update”).
      ‎Figure 3: “Feature Update”

  3. Now add the PDT project's download site:
    • Click on the button “New Remote Site” (see Figure “Update sites to visit”).
      Figure 4: “Update sites to visit”

    • Enter a name, e.g. "PHP Development Tool (PDT)", and the following URL: http://download.eclipse.org/tools/pdt/updates/
  4. We now have to choose all sites we want to include in our search:
    • Make sure "PHP Development Tool (PDT)" (the entry we just created) is checked.
    • Check as well "Callisto Discovery Site" and "The Eclipse Project Update".
    • Click on Finish.
  5. Accept default Download Sites if asked for.
  6. Finally, you will be presented a list of features (see Figure 5: “Updates Search Results”). While browsing the tree, check the following features (if one of these features is not shown in the list, it means that it is already installed)(:
    • Check "Callisto Discovery Site > Web and J2EE Development > Web Standard Tools (WST)"
    • Click on the "Select required" button on the right.
    • Check "Callisto Discovery Site > Models and Model Development > EMF Service Data Object (SDO)" (only needed if you want to manage your databases within Eclipse)
    • Check "PHP Development Tool (PDT) > PDT > PDT Feature"
      Figure 5: “Updates Search Results”

  7. Click on Next and further follow the on-screen instructions to finish the automatic install.

Note: A video can be seen here

Note: There may be a problem during automatic installation, if you use the "Install All" button during the Eclipse "Find/Install" feature. If the installation stops with an "connection timed out" message (when downloading additional files), close and restart Eclipse and use the "Install" button instead of the "Install All" button - this will require you to start the installation of the (currently) four packages manually but resolves the problem.

Linux Users:

If you use Eclipse package provided with your system, you may have to run Eclipse as 'root' to install plugins, otherwise you will have to change the plugin installation directory to somewhere in your HOME directory.

Windows Vista Users:

The first time you want to add plugins to a freshly installed Eclipse Platform, you have to run Eclipse with 'Administrator' rights (see context-menu when hovering the program icon), otherwise you will get an error message.

Manual

Note: While the PDT plugin can also be installed manually, this is not the recommended way. If possible, prefer the "Automated" method because the Eclipse Update Manager keeps track of all dependencies. If you choose Manual method, you have to install all requirements manually and take care of dependencies yourself.

To install PDT manually, first download the latest version of PDT (for your Eclipse version) from eclipse.org at [1].

The latest version will be the one at the top of the list displayed on the download page.

The PDT zip file must be extracted in the same directory in which you installed Eclipse. It contains two directories, plugins and features, and these must match to the plugins and features directory in your existing eclipse directory.

Then you must take care of needed requirements. You have to check that they are not already installed and that they met the minimum version number required for PDT:

  1. EMF version
  2. GEF version
  3. Java EMF Model version
  4. Eclipse version
  5. WTP version

Note: Eclipse 3.x caches all plugin.xml files into a single repository for quicker loading. If you used eclipse before installing PDT, you should start eclipse once with the -clean option. This -clean forces Eclipse to rebuild that repository. This applies to anything that is installed into eclipse by unzipping it into its plugins folder.

Note: As with Automated method, you have to disable PHPeclipse.

After extracting PDT and needed requirements, (re)start Eclipse. PDT will be loaded automatically. If NOT, you should Enable it manually.

Open the Help > Software Updates > Manage Configuration menu and click the Show Disabled Features button from the toolbar if not enabled yet.

In the tree menu, you should not have any plugin with a red icon other than those you have manually disabled. It not, you have dependancy errors.




Up | Back | Next

Personal tools